اخبار امنیت وب
موضوعات داغ

وردپرس 5.2.3 بر روی امنیت تمرکز می کند!

در آپدیت جدیدی که وردپرس به تازگی منتشر کرده است خیلی از مشکلات امنیتی و مشکلات فنی نسخه قبلی برطرف شده است که به آن می پردازیم.

نسخه جدید وردپرس 5.2.3 نام دارد که یک نسخه تعمیر می باشد که 29 مورد از مشکلات نسخه قبلی برطرف شده است و همانطور چند مشکل امنیتی در این نسخه رفع شده است.

همانطور وردپرس اعلام کرد مشکلات امنیتی و فنی روی نسخه وردپرس 5.2.2 تاثیر می گذارد. و در نسخه 5.2.3 که ارائه داده است این مشکلات برطرف شده است.

همچنین اگر شما وردپرس خود را به 5.2 بروز نکرده اید موردی ندارد زیرا که در نسخه 5.0 و نسخه های بالاتر مشکلات را برای شما برطرف می کند.

وردپرس 5.2.3 یک نسخه تعمیر و کوتاه مدت است نسخه اصلی آن نسخه 5.3 است

مشکلات امنیتی برطرف شده

  • آسیب پذیری cross-site یا XSS که در پیش نمایش های پست وجود داشت
  • آسیب پذیری cross-site یا XSS که به دلیل کدنویسی در قسمت نظرات ذخیره شده بود
  • آسیب پذیری مربوط به برنامه نویسی در سطح سایت (XSS)
  • برطرف کردن مشکل cross-site scripting در داشبورد سایت
  • ضد عفونی URL که می تواند منجر به حملات اسکریپت درون سایت (XSS) شود.
  • متوقف کردن Anshul Jain به دلیل ایجاد باگ XSS در هنگام بارگذاری رسانه ها
  • ضد عفونی شدن یک URL که می تواند منجر به تغییر مسیر باز شود. (redirect)
این مطلب را از دست ندهید:  حملات شدید سایبری به وبسایت های فروشگاهی وردپرس

از دیگر تغییرات می توان به آپدیت نسخه jQuery در نسخه های قدیمی وردپرس اشاره کرد. این تغییر در وردپرس 5.2.1 اضافه شده است و اکنون به نسخه های قدیمی تر نیز راه یافته است.

اما اگر تمایل به آپدیت دارید، یعنی بردن وردپرس به نسخه 5.2.3 از قسمت پیشخوان می توانید پیغام آپدیت جدید را مشاهده کنید که با کلیک روی هم اکنون بروزرسانی نمایید این کار امکان پذیر است.

اگر بروزرسانی خودکار سایت شما فعال است این کار به صورت خودکار انجام می شود که دیگر نیاز به بروزرسانی دستی نیست .

آرین لاوی

آرین لاوی هستم؛ هم بنیانگذار " آقای امنیت " که حاصل تجربه های خودم در حوزه تخصصی امنیت وب و امنیت وردپرس را برایتان می نویسم و تلاش میکنم به شما کمک کنم تا وبسایت امنی داشته باشید.

نوشته های مشابه

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

بستن